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Chapter 1

Introduction

1.1 Overview

Tigertrak Sentry is a real-time database monitoring utility designed specifically for use with Tigerpaw Software’s
CRM business software. Sentry’s primary function has become its accounting link designed to automate the transfer
of accounting data from Tigerpaw to your choice of accounting software.

1.2 Conventions used in the document

The following conventions are used in this document:

• File names, paths, and program output will be displayed in fixed-size font: c:\foo\bar.txt

• Object names, menus, and dialogs will be listed in Italics; sub-menus will be pointed to with a redirect character
(>): Click on the Start button > Programs > Tigertrak > Sentry > Sentry shortcut

• All commands and user input will be shown in bold typeface

1.3 Terms used in this document

This document contains terms that may need a more detailed explanation before you begin.

Host System – The Computer that Tigertrak Sentry is installed, and running on.

Accounting System / Software – The accounting package in use. Currently supported accounting packages are
QuickBooks, and PeachTree.
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Chapter 2

Getting Started

2.1 How Sentry Works

Sentry is designed to work in a fail safe manor, alerting the administrator to potential problems through log files.
In most instances if a particular component is to fail other tasks will continue to be processed. Sentry attempts to
resume where it left off, processing any uncompleted tasks once available again.

2.2 Installation Procedure

Prerequisites

In order to install, and use Tigertrak Sentry there are several requirements which must, or should be met.

• The latest version of Tigerpaw must be properly installed, configured, and operating; it is not necessary to
have Tigerpaw on the same computer that Sentry will be run on

• Microsoft Windows 7, Vista, XP, or Windows Server 2003/2008 with latest service packs, and patches applied

• QuickBooks [US versions newer than 2006, Enterprise versions newer than 6.0] must be installed with the latest
patches on the designated computer to run QBTrak, the accounting link module; editions Enterprise, Premier,
or Pro are supported

• Peachtree version 2004 and higher must be installed with the latest patches to run the Peachtrak accounting
link

• The Tigerpaw Accounting Link must be properly setup between Tigerpaw CRM+ and the accounting system

• Local administrative rights on the PC where Sentry is to be installed and run

Installation

Sentry must be installed on a computer where the accounting software is available and operating. We require the
accounting software’s user interface to connect to the accounting file - this means that installing on the QuickBooks
server is not sufficient unless the QuickBooks user interface is also installed there.. Tigertrak Sentry can only be
installed on one computer, to connect with one database, and one accounting system.

1. To install, execute Tigertrak Sentry’s Setup.exe and follow the on-screen instructions

3
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Setup

After the initial installation, Sentry must be configured before it begins working.

Open Sentry, by finding it’s shortcut in the start menu (click on Start > Programs > Tigertrak Sentry > and run
the Sentry shortcut). When running Sentry for the first time, the Setup Wizard will open automatically to guide
you through the minimum configuration necessary. See Figure 2.1 below.

Figure 2.1:

After completing the wizard, additional configuration can be done in the General Options dialog (File > General
Options). See below for field descriptions. We no longer recommend the SMTP settings be filled in. Problems are
concisely reported in logs which will be covered later.

Select Database – Select your Tigerpaw server and database by clicking the Select Database button. Follow the
wizard for creating a new database connection, or choose the database from the list. Using SQL Authentication
is recommended.

SMTP Server, Port – Enter the IP address of your SMTP server. At the time of this writing, Fully Qualified
Domain Names, and computer names are not supported. The default TCP port for SMTP service is 25.

User Name – Should be a fully qualified email address (user name@domain.com); this will be the user that Sentry
sends e-mail messages from.

Display Name – The name that displays on email messages sent from Sentry. It is recommended you place
quotation marks around the name “My Company, INC.”

Reply Address – An optional field specifying where returns should be mailed to, other than the User Name field.

Administrator Email – Sentry errors, and information will be addressed to this user

Send program errors to administrator – It is highly recommended this option is checked. When critical errors
occur, a copy of the error details are mailed to the designated Sentry administrator. A copy is also automatically
sent to Tigertrak for analysis.

Send Test – Test the email functionality by sending a message containing the error log, the installation log, and
the status log. A dialog will appear asking if a copy should be sent to Tigertrak support. A message box will
alert you to the status of the test. If successful, an e-mail will have been sent to the administrator’s e-mail
address containing program information, and a copy of the error log.

Execution Interval – Set the interval time for Tigertrak Sentry. This is the time between the rule loop being
executed; 10 minutes is the default, which is recommended.
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Automatically Report Errors to Tigertrak – When selected, this option automatically emails a copy of indi-
vidual errors encountered while running Sentry to support@tigertrak.net. This option only works if e-mail
settings have been properly setup.

Automatic Updates – Automatic updates enables Sentry to check for, download, and install program updates
automatically over the Internet. If this option is disabled, Sentry will log when updates are available in the
Status Log, but will not automatically download, or install them.

Uninstallation

Tigertrak Sentry can be uninstalled by finding it in the Add or Remove programs dialog of the Control Panel.

2.3 Operating Sentry

Interface

Sentry’s main screen displays information about the state of Sentry. Information such as what Sentry is currently
processing, the status of such events, and brief notes about any potential problems encountered. The most up-to-date
information is shown at the top of this list; the older items move down this list. The data displayed here is saved to
the Status Log.

Menus

Most of the menus are self-exclamatory, but we’ll explain the important ones here.

Under the File menu:

General Options – Basic settings for Sentry including database selection, SMTP server settings, and other global
options affecting Sentry’s operation. The General Options are described in the Setup section 2.2, Installation
Procedure, in this manual.

Module Selection – Displays, and allows enabling / disabling of installed Sentry modules. This dialog will also
provides access to module settings. Modules must be activated before Sentry will do anything. Chapter 3:
Modules explains each module in depth.

Template Editor – Form for creating e-mail templates with data tokens for mailing dynamic messages.

Under the Advanced menu:

Verbose Status – Enables or disables verbose status output. With verbose on, Sentry prints much more detail
to the status log, such as each successful execution within a module, as opposed to just errors, warnings, and
a summery of the outcome. Turning this option off makes visually reviewing the status log much easier, but
enabling it can help support with diagnosing problems, so it’s usually recommended it be left off unless you’re
experiencing trouble.

View Status / Error Log – Easily access the logs. If you are experiencing problems that require support, we’ll
often ask you to send these logs to us for review.

Under the Help menu:

Wizard – If the setup wizard was not completed, the wizard can be launched using this menu entry. After comple-
tion, the wizard will no longer be available.

Registration – Manually launch the registration dialog. The dialog can be used to view registration information
such as number of days remaining in a demo, or information about available upgrades. Support may occasionally
suggest you reregister your product to activate new features.



6 CHAPTER 2. GETTING STARTED

Template Editor

Sentry has a built-in template editor which allows for the creation of e-mail templates. These templates can be
crafted to contain dynamic data by inserting Tokens. To insert a token, click the Token button, select a category,
and double click a specific data token; it will appear at the cursors current location in the template editor. Be sure,
when creating templates, that the tokens used are related to the intended purpose of the template. For example,
Purchase Order tokens are unlikely to work when sending an e-mail notification about Contracts. A token is simply
not populated if it’s data is not available.



Chapter 3

Modules

Modules must be enabled in Sentry before anything is processed. Modules can be activated, and deactivated under
the File > Modules Selection menu. Each module, or sub-module options page has a checkbox at the top which
indicates if the module is turned on or off.

Figure 3.1:

3.1 Contract Expiration

As of Sentry Release 20, the Contract Expiration module has been removed from Sentry.

Contract Expiration is designed to help keep contracts up to date. As a contract nears it’s dated expiration, e-mail
notifications can be sent out to your customer, your operator (Tigerpaw representative who created the contract),
your sales team (representative to receive credit for the contract sale), or the primary technician assigned to the
account. Each of these recipients can be alerted with a different e-mail template (created with the Template Editor
described in section 2.3), uniquely crafted for them.

There are three warnings before a contract expires. Each warning period is a user- configurable number of days
before the dated expiration of the contract. When a contract falls past a warning period, an e-mail notification can
be sent to the customer, operator, sales team, or contracts assigned technician.
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When e-mailing the customer, Sentry uses either the primary email address of the designated contact for the contract,
the primary e-mail address of the account, or the primary e-mail address of the account’s primary contact, respectively.
A warning will be issued to the status list if the email could not be sent. If the notification successfully sends, a
Journal Note will be created for the account containing the e-mail message in it’s entirety. The journal note will
have been created by the Tigertrak Sentry user.
If sending to the Tigerpaw rep who created the contract, the rep to credit, or the assigned tech, the “E-mail 1” field
from Account Reps settings in the master tables is used. A warning, or journal note will be issued as well for rep
emails.

3.2 Service Order Escalation

Service Order Escalation was created to enforce contracted service orders with a set time to respond. When a service
order is created under a contract, and that contract has a specific response hours field set, Service Order Escalation
can be enabled to escalate either the status, or priority of a service order incrementally.
Choosing whether or not to escalate the priority or status is the first step in configuring Service Order Escalation.
Next, would be to determine the time periods before the deadline of when to escalate, and the priority/status to
escalate to. The highest time period, and first level of escalation should be set at the top of the escalation list, as
shown in Figure 3.1.
Sentry will not allow you to escalate the status of a service order to a status which will automatically close it, however
be careful, and do not automatically escalate to a status that would be considered responded to as the next section
will show. Select which statuses will be considered responded to. When a rep changes the status of a service order
to a status that is considered responded to, Sentry will no longer continue escalating that service order, considering
it attended to. Several Tigerpaw reps can be informed of this escalation activity through e-mail. E-mail notification
works identically to the Contract Expiration module described in the previous section.

Figure 3.2:

3.3 Closed Service Order Reports

Closed service order reports generate a nightly Acrobat document reporting information about the previous days
closed service orders. Specifically, these reports contain a field marking whether or not the service order is considered
billable.
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There are three steps to configuring this module. First, select the reps who are to receive this daily report. Next
choose the Contract Types that are exempt from billing. Finally, there is the option to inverse non-billable contracted
service orders. This is done by selecting which service order profiles (available under the Codification tab) in a service
order in Tigerpaw will be marked as billable, despite their belonging to a non-billable contract type.

3.4 Customer Service Order Reports

The customer service order report module generates, and e-mails an end-of-month report of closed service orders
to accounts who belong to selected groups. After enabling, simply choose which account groups should receive this
monthly list.

Sentry first searches for the account’s primary e-mail address, then searches for the primary contact’s e-mail. Some
accounts, or contacts may have the “Do Not E-mail” option set in Tigerpaw; Sentry has the option to honor this
request, or bypass it.

The “Test” button randomly selects up to three accounts, and generates a report which is sent to Sentry’s adminis-
trator e-mail address (although, if too few accounts exist in the selected account groups, there is a chance no accounts
are found).

3.5 Scheduled Service Order Reports

A report of the month’s scheduled service orders is available with this module, emailed to selected reps.

The report is limited by choosing only desired service order types included in the report. Reps who are to receive
the report are then selected.

3.6 Automated Accounting Link

The QBTrak, and Peachtrak modules are our accounting link modules working as a medium between Tigerpaw
CRM+ and the accounting system. It works with the existing Tigerpaw batching system, so manual batching is still
an option while using Sentry.

Configure Tigerpaw’s accounting interface

Before the accounting link can be automated using Sentry you must setup the accounting link between Tigerpaw
and QuickBooks. The accounting link is configured in Tigerpaw by navigating to the Tools [menu] > Accounting >
Create & Configure Accounting Batches. This will display the Accounting Options dialog. This is the dialog where
you can manually create batch files, or view and edit transactions waiting to be exported to accounting.

From the Accounting Options dialog, selecting the Configure Accounting icon will bring you to the interface for
configuring accounting. For QuickBooks you must configure the QuickBooks Pro Enhanced, and for Peachtree the
Peachtree Complete accounting link.

This accounting link must be properly configured, and working before you can continue. If you are unfamiliar with
the function this Accounting Options dialog, please contact Tigerpaw Support for instructions on configuring your
accounting interface, and for creating manual batches. If you contact Tigertrak for support, we may refer to this
dialog as “the batch”, and it helps to have a basic understanding.

Establishing a link between Sentry and your accounting software:

The accounting modules link to either QuickBooks, or Peachtree (described below), and its ability to perform
functions within the accounting system is contingent on the host system’s ability to connect to the accounting
software’s data file. If another system has locked the company file (in single-user mode, for example with QuickBooks),
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Figure 3.3: Accounting Options and Configure Accounting Interface
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and Sentry cannot connect, processing of accounting functions will be halted until access to the company file resumes.
At this point Sentry will automatically reconnect and begin automation where left off.

Before the accounting functions will work, a link must be established between Sentry and the accounting link:

1. Be sure the accounting software is running, and the desired company file is open

2. In Sentry, open the accounting link module settings (File > Module Selection > QBTrak / PeachTrak: Ac-
counting Link)

3. Click the Connect to QuickBooks / Peachtree button, and browse to the company file, or folder

4. Finally, allow access to Tigertrak Sentry when prompted by the accounting software; it is recommended Sentry
is granted access to QuickBooks even when QuickBooks is not running - Peachtree does not allow this option

Additionally, accounting objects must be equal between Tigerpaw, and the accounting package. Items such as GL
codes, tax codes, terms, and others must be created, and matched in value.

QuickBooks-specific:

When establishing a connection from Sentry to QuickBooks, a special user should be created which QuickBooks uses
to connect with. We recommend creating a user named “Tigertrak”. This additional user does not use an additional
QuickBooks license. If you have already granted access to Sentry under another user, this new Tigertrak user can be
set by go to Edit > Preferences > Integrated Applications > Company Preferences [tab] > and the Tigertrak Sentry
Properties. Use the drop-down list to select the newly created Tigertrak user.

3.6.1 Account Exportation

The Account Exportation module exports account information between Tigerpaw, and the accounting system. En-
abling this option collects accounts which have been flagged with the Export Customer Information to Accounting
check box set under an Account’s Accounting Information dialog in Tigerpaw. For existing accounts which have been
flagged again, the Account Export will update the information. The exception to customer modifications is when the
ARCustomerNumber is changed in Tigerpaw: when exported, a new customer with the new ARCustomerNumber
will be created, and the accounts must be manually merged in the accounting system.

QuickBooks-specific:

Vendors will also be exported to QuickBooks using this module. Vendors are linked to QuickBooks with their
APVendorID, which can be set in the Vendor Information dialog (found by clicking the [...] button next to Is A
Vendor check box). Sentry may create, or change the APVendorID value automatically (by appending a “ (V)”) if
the ARCustomerNumber of the account has been filled in, and is identical to the APVendorID.

If both the ARCustomerNumber, and APVendorID are filled in when an account being exported, and is flagged as
a vendor, Sentry will export the account as both a customer, and vendor.

Sub-accounts, or jobs can be exported to QuickBooks by assigning an A/R Customer Number specifying the parent
account, and sub-account, or job name in the format Company:Job.

3.6.2 A/R Exportation

The A/R Exportation automates the A/R Batch process previously used to export invoices from Tigerpaw to the
accounting system. Enabling A/R Exportation automatically enumerates posted Invoices or Credit Memos and
exports them.

All A/R Exports — in addition to being listed in the Status, and Error Logs — are logged to a results table in
the database for review. Under the accounting link module, in the Invoice Export sub-module, the Results Browser
can be opened to show information about posted invoices that Sentry found. The results of exports are shown as
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SUCCESS, WARNING, or FAILURE. If Details for that specific export were recorded, the full text can be reviewed
by double-clicking it’s entry. Problems can often be diagnosed by reading these errors.

Sentry will attempt to export invoices only once. If there is a problem with the exportation, and an error is logged,
the invoice will not attempt to export again until the results table is cleared. Once the results table is cleared, all
invoices that had previously failed will attempt to export again.

QuickBooks-specific:

Individual Line Items within an invoice, or entire invoices belonging to an account which is to be categorized under a
Department/Class will be imported to QuickBooks under the designated Department/Class. If the Department/Class
does not exist in QuickBooks, it will be created by Sentry.

Filing of invoices in QuickBooks under different locations belonging to the same company is supported by Sentry.
In QuickBooks, these locations are traditionally called “Jobs”. To take advantage of this feature, use a colon (:) to
separate the company name from the location in the ARCustomerNumber. For example: “Company:Job”.

Tiered tax is supported in Tigerpaw, but not QuickBooks. To correct this issue we require that tiered tax codes
in QuickBooks must be set to a 0% rate. Tax calculated in QuickBooks will then come over as line items, rather
than calculated separately between the two programs. Unfortunately, because QuickBooks does not natively support
tiered taxes, QuickBooks reports will not be accurately populated. Sales tax reports should be run exclusively from
Tigerpaw if you are effected by this issue.

Send Tax As Line Items - - When checked, tax will not be calculated separately between Tigerpaw and Quick-
Books. Instead, tax will transfer to an invoice through line items. This option can be used to correct issues
with tax rounding or to avoid manging tax codes between both programs. The disadvantage of this option is
that QuickBooks sales tax reports are not as accurate when sending tax as line items.

Peachtree-specific:

Credit limits must be turned off for customers so that invoices can be exported. This can be done in the Maintain
menu > Default Information > Customers > then select the Terms and Credit panel and select “No Credit Limit”
from the Credit Status drop down box.

3.6.3 G/L Exportation

G/L Exportation automates the batch process previously used to export G/L information. Operation is nearly
identical to that of the A/R Exportation of Tigertrak Sentry.

3.6.4 Automatic Credit Hold

Automatic Credit Hold is a feature which automates the task of finding customers with overdue balances in the
accounting system, and marking them for Credit Hold in Tigerpaw. Not only is an account put on credit hold, but
also a note is written to the credit hold special instructions field in Tigerpaw indicating that Tigertrak Sentry flagged
the account, the amount overdue, and the date Credit Hold last flagged this customer. Sentry removes customers
from Credit Hold once their balance has been paid. Tigertrak Sentry will not remove customers which have been
manually placed on credit hold by a Tigerpaw Representative. Customers in Tigerpaw are flagged based on their
AR Customer Number matching between the accounting system, and Tigerpaw. This results in all accounts sharing
a single AR Customer Number in Tigerpaw being flagged for credit hold.

Days since invoice date – Controls the definition of overdue. Invoices can be considered overdue when they are
more than 30, 60, or 90 days late.

Debt greater than – A threshold value limiting which accounts should be placed on credit hold. Overdue debt
greater than this value will cause an account to be put on credit hold, while debt less than this value will be
ignored.
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Hour to run – Option to change the time of day when the Credit Hold sub-module will execute. Set this option
to a time of day the computer is most likely to be running, while doing the least amount of work.

Account Groups Never to Credit Hold – Accounts belonging to selected account groups will never be flagged
for Credit Hold.

Clear Credit Hold – Clears all customers currently on credit hold.

Run Credit Hold – Runs the credit hold sub-module manually.

QuickBooks-specific:

An invoice aging report can be generated for each account placed on Credit Hold, and attached to the customers
documents folder in Tigerpaw for a detailed reference of overdue invoices. This feature is enabled when an Account
Documents path is set in the Scanning Options in Tigerpaw (Tools > Options > Scanning > Account Documents).
The path selected must be available the system hosting Sentry, and should be available to all Tigerpaw CRM+ client
workstations; i.e. a server’s file share. A UNC path is recommended (for example: \\myserver\myshare\myfolder).

Figure 3.4:

3.6.5 Payments Exportation

Exportation of receipts, and payments entered into Tigerpaw is supported by Tigertrak Sentry. When a receipt is
entered, and applied to invoices for an account, Tigertrak Sentry will attempt to update the accounting system with
the payment information. Payments, additionally, are applied to their corresponding invoices.
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As of Tigerpaw CRM+ version 10.6, over payments are supported. In addition to suppurating the Tigerpaw overpay-
ment functionality, if a payment applied to an invoice in Tigerpaw exceeds that which is expected in the accounting
system, the additional funds are carried over to the accounting system, not unapplied. It should be noted that
with this type of over payment, the funds are deposited to the account which the payment designated for, not the
designated account to receive over payments. Note: PeachTrak does not support versions of Tigerpaw prior to
10.6.

Tigerpaw-QuickBooks Tax Rounding Fix – Because invoice taxes are calculated separately between Tigerpaw
and QuickBooks when using Sentry, a rounding error between the two programs can create a situation where
invoice tax rounds up to be one penny more in QuickBooks than in Tigerpaw. To address this issue, you can
check this box which will add $0.01 to a payment if the remaining balance would otherwise be $0.01 after
payment is applied.

Payment results can be viewed with the Show Results button under the Payments sub- module. The results of
exports are shown as SUCCESS, WARNING, or FAILURE. If Details for that specific export were recorded, the full
text can be reviewed by double-clicking it’s entry. Problems can often be diagnosed by reading these errors. After a
problem has been resolved, if the results are Cleared, Sentry will attempt to reexport next time.

3.6.6 Purchase Order Exportation (QuickBooks only)

Once this module is enabled, Purchase Orders are created, and updated as PO receipts are posted in Tigerpaw. Each
time a receipt is posted in Tigerpaw, the Purchase Order is duplicated in QuickBooks, and, optionally, a Bill can be
created against the PO for the items received.

There are five conditions that must be met before Purchase Orders will begin queuing for exporting:

• AP Feed must be enabled in Tigerpaw (Tools > Accounting > Create and Configure Accounting Settings >
Configure Accounting Interface > General [tab])

• There cannot be a Default GL Receipts Code set in the accounting settings (marker 1)

• There cannot be any GL Receipts Codes set for any parts

• A Freight Credit Account must be set for Bills to be created (marker 2)

• A PO Receipts GL Account should be set - this is not mandatory, but not configuring may prevent exporting
(marker 2)

These requirements are itemized in the options for this module. If these requirements are not met, the module can
not be activated, and the unmet requirement will be displayed in red.

When using Purchase Order export, first a purchase order is created in Tigerpaw. Sentry does not immediately
export purchase orders when they are created! Instead, the purchase order is created when the first item receipt is
posted. Purchase orders can be modified in Tigerpaw even after being partially received. Changes to the PO are
updated in QuickBooks. There is one limitation to keep in mind: although Tigerpaw allows more than one instance
of the same Pricebook Item to appear on separate lines in a PO, Sentry cannot support this.

Note: It is important to understand that, when enabled, this module will create inventory items in QuickBooks as
they are encountered. Over time, the creation of thousands of parts can slow the operations of QuickBooks,
and an upgrade to the Enterprise version may be necessary.

Note: The items created for this module will have a similar name to that of the Item ID in Tigerpaw, and contain
the item number associated with that part. These item names cannot match Tigerpaw’s items exactly. These
items are also created as “Other Charge” items to avoid having to manage them as part of the QuickBooks
inventory.
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Figure 3.5: PO Export Prerequisites

3.6.7 Job Costing (QuickBooks only)

To fully utilize the power of Job Costing, the Purchase Order, and Invoice Export modules must be enabled.

Job costing starts with a quote. A quote must be marked for job costing by enabling it for exportation in the quote
custom fields. Once the quote is marked for export, and converted to a Service Order, Sentry will create a job (as
the quote number) in QuickBooks under the account the quote is for. So if quote number 212 is created for “Bob’s
Store”, the job “Bob’s Store:212” will appear in QuickBooks and the quote will be exported as an estimate to that
newly created job.

Next, as the Service Order is completed, the invoice will be exported to the job as well. Inventory parts will be
created for the invoice if they do not exist, as specified above in section 3.6.6 Purchase Order Exportation. A journal
entry transaction will be entered against the job to debit the value of parts pulled from inventory.

The Purchase Order module will, if the option to Create Bills has been enabled, link PO line items for a job to the
job when the vendor bills are created.

3.6.8 Time Sheet Export

Exporting time slips from Tigerpaw to QuickBooks time sheets is a feature offering two benefits. First, time sheets
add the final piece to the Job Costing process. With time sheet export enabled, the cost of labor is accounted
for within a job that was created in QuickBooks. Next, time sheet export can be used to link Tigerpaw to the
QuickBooks payroll services.

Configuration is as simple as specifying the QuickBooks Payroll item to use for each combination of Tigerpaw’s Time
Rate Basis + Time Log Reason, and relating Tigerpaw reps to QuickBooks reps.

Rate Basis + Time Log Reason = Payroll Item

Time logs in Tigerpaw contain a Rate Basis and Time Log Reason to calculate the value of time. QuickBooks has
Payroll Items. By relating Tigerpaw’s Rate Basis and Time Log Reason to a QuickBooks Payroll item, different
outcomes for the cost of the labor accounted for.

For example, you may have a Time Log Reason of “repair” in Tigerpaw. This “repair” reason can have a Rate Basis
of “regular”, or “overtime”. There is probably a cost and income difference between these two rates, but QuickBooks
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only allows Payroll Items. To accurately match the value of time between Tigerpaw and QuickBooks two QuickBooks
Payroll Items can be created: “Repair - Regular”, and “Repair - Overtime” we’ll call them. Finally, in Sentry, match
the combination of Rate Basis + Time Log Reason to the proper QuickBooks Payroll Item.

Relating Reps

Reps must be matched between QuickBooks and Tigerpaw, and these reps must be manually related for the Time
Sheet export module to work correctly. Time logs will not move to QuickBooks if the rep in Tigerpaw has no
counterpart in QuickBooks.

Figure 3.6: Time Sheet Export Configuration

3.7 Avalara AvaTax Connector

Tigertrak Sentry provides a connector to Avalara’s AvaTax services. Avalara provides a service to automatically
find tax rates, and amounts for invoices based on the originating, and destination locations. Please review Avalara’s
website for detailed information on what the AvaTax service can provide, and contact Tigertrak for rates and service
activation.

The Avalara process works by intercepting invoices after approval. Once an invoice, marked with the AvaTaxGroup
tax code, has been approved, it will be put on hold, and cannot be posted until Tigertrak Sentry processes the AvaTax
request. After a successful AvaTax request is made, the invoice can be posted, and exported to to the accounting
package. See the entry below for more specific information on the Avalara process.

It is important to understand our Avalara integration does integrate with all areas of Tigerpaw. Below is a brief list
you should review. If any of the following items sounds concerning, you can learn more in the Errata section of the
manual’s Appendix [B].

• Quotes are not supported

• Central Billing Invoices are not currently supported

• Tax Credit Memos are not supported

• Price Credit Memos are not exactly perfect

• Progressive billing is supported with caveats

• Prepaid contracts
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3.7.1 Basic Setup

Some additional configuration is required before using the Avalara module.

AvaTax Tax Code & Disctrict

The tax code district [AvaTax], and tax code [AvaTaxGroup] used to mark invoices for processing are automatically
created in Tigerpaw by Sentry, however the GL Code and Vendor ID must be assigned to the tax district [AvaTax]
before using the Avalara module. Failure to configure this will result in invoices not posting until corrected. See
figure 3.7. These tax items must be created manually in the accounting system.

Sales Tax Origin Addresses

To accurately calculate sales tax Avalara takes into account not only the destination of a sale, but from what location
items came. Inventory Locations (Edit > Master Tables > Inventory > Inventory Locations) should have accurate
address information. If an inventory location has no address information associated with it, the address used is
the company’s main address (Tools > Options > Company) which must be completed for accurate sales tax rate
calculation.

Figure 3.7:

Avalara Dashboard & Custom Tax Codes

Avalara provides an on-line administrative page called the “Dashboard” which requires a minimum configuration.
There are 5 custom tax codes which must be created to match the default tax codes built into Tigerpaw. These
codes are “F” - Finished Goods which are a type of Product; “FC” - Freight Charge which is a type of Freight; “L”
- Labor for Service; “M” - Material for Product; and “S” - Special for Other types of product. See figure 3.8.

Figure 3.8:

Sentry’s Avalara Module

Finally, the Avalara module settings in Sentry must be configured (File > Module Selection > Avalara AvaTax).
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Figure 3.9: Avalara Module Form

Avalara Account Number / User Name & Password –Avalara web service credentials.

Primary / Secondary Web Service URL – Avalara provided web service URL.

View Flagged Documents – If an error is encountered while processing an invoice or credit memo, the document
will become flagged. View these flagged documents, and the errors associated with them them by clicking
the View Flagged Documents button. This is also where flagged invoices and credit memos are cleared for
reprocessing.

View / Edit Tax Codes – Relate specific tax codes to items in the Pricebook using the AvaTax Coder.

Authenticate Account – Test provided credentials, and Web Service URL.

Entity Use Code Options – Add, Edit, and Link your Service Order Types to specific Entity Use Codes. (This
feature is optional, See figure on page 20for details)

At this point, after configuring the credentials, and service URL’s, the Avalara module is able to be used. However,
to get the most value from your AvaTax requests, specific tax codes should be related to your Pricebook items in
Tigerpaw. This is done in Sentry’s Avalara module options with the AvaTax Coder. Items in an invoice which have
not been matched to a specific tax code will default to the item type defined in Tigerpaw, as described above. (See
figure 3.8 on the previous page)

3.7.2 Assigning Tax Codes to Pricebook Items

(File > Module Selection > Avalara AvaTax > View / Edit Tax Codes).

Here you can assign a Tax code to each of your Pricebook Items. Items in an invoice which have not been matched
to a specific tax code will default to the item type defined in Tigerpaw, as described above.

Note: Tax Codes may also be set from inside Tigerpaw. This can be done by opening the item inside the Pricebook
and clicking on the “Custom Fields” button. (See figure 3.11 on the facing page)

Please see 3.10 on the next page to reference the list below.

1. Pricebook Items: Every Item in your Tigerpaw Pricebook will be displayed here.

(a) Clicking on a table header will allow you to sort that columns data by Ascending order, clicking the
column again will switch to Descending order. (note: the columns are re-sizable)

(b) Single-clicking on an item will display more detailed information below this list (Read #5)
(c) Double-clicking on a Pricebook Item while in “Custom Tax Codes” mode (Read #2 and #4) will assign

the custom code to the selected Pricebook Item.
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2. Coding modes: “System Tax Codes” and “Custom Tax Codes”

(a) Selecting “System Tax Codes” (default) will allow you to access and use Avalara’s System Tax Codes
(Avalara customers will need to make sure their subscription to AvaTax includes the use of these “System
Tax codes”)

(b) Selecting “Custom Tax Codes” will allow you to manually define your own Tax Codes. (Read #4)

3. System Tax Code interface: Here you can view the supported System Tax Codes from Avalara

(a) By default, every system tax code is displayed. You may use the “Tax Codes Filter” drop-down to only
display a specific category.

(b) With a Pricebook Item selected, Double-clicking on a System Tax code will assign the tax code to the
selected item.

4. Custom Tax Code interface:

(a) Entering a Custom Tax Code here, then Double-clicking on any Pricebook Items will assign the Custom
Tax code to the item.

5. Item Details: When selecting a Pricebook item, this area will be populated with some additional descriptive
information. The main purpose of this area is to provide additional assistance when dealing with many items
with similar names or descriptions.

Figure 3.10: Avalara Tax Coder Form

Figure 3.11: Setting a Tax Code inside Tigerpaw
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3.7.3 Entity Use Codes: Linking Tigerpaw’s Service Order Types and Avalara

(File > Module Selection > Avalara AvaTax > Entity Use Code Options).

This is an optional feature that will allow you to associate a specific Entity Use Code to every Service Order set to
use Avalara, based on the Service Order’s Type.

For example, Maybe you’d want every “Installation” type Service Order that is created and processed by Avalara to
also use a specific Tax Entity Use Code.

Please contact Avalara for assistance in setting up and supporting entity use codes.

Entity Use Codes are Case Sensitive, In order to properly link the codes, please make sure to enter
them into this form exactly how they appear on the Avalara Dashboard

(See Appendix:A on page 26 to learn about Case Sensitivity)

When Sentry is executed for the first time, several Entity Use Codes will be created. If you do not need them, they
may be deleted (see steps below on how to manage the Entity Use Codes in Sentry).

Please see figure 3.12 on the next page to reference the list below.

1. Tigerpaw Service Order Types

(a) Clicking on a Service Order Type will display the Entity Use Code (Read #2) currently assigned to the
selected Service Order Type.

2. Entity Use Codes List: Here is list of available Entity Use Codes, The left side displays the actual Entity Use
code and the right showing a brief description (Note: You may Add/Delete Entity Use Codes, Read #3)

(a) With a Service Order Type already selected (Read #1), Clicking on a Entity Use Code will assign the
selected code to the selected Service Order Type.

3. Add Codes button: Loads the Entity Use Code Manager form.

4. Use this area to add new Entity Use Codes

(a) Please contact Avalara for assistance in setting up and supporting entity use codes.

(b) Entity Use Codes are Case Sensitive, In order to properly link the codes, please make sure to enter them
into this form exactly how they appear on the Avalara Dashboard

(c) (See Appendix:A on page 26 to learn about Case Sensitivity)

5. Entity Use Code Master List: Displays available Entity Use Codes and also allows you to check-off codes you’d
like delete.

6. Remove Selected Item(s): Removes the selected codes from the Master List (Read #5)

(a) WARNING: It is possible to delete an Entity Use Code that is currently being used by a Service Order
Type.

i. Before deleting an Entity Use Code, please make sure it is not being used by any Service Order Types.
(Read #1)

ii. If a Service Order Type is assigned to a code you wish to remove, simply set the SO Type to “--
None --” before removing. (Read #1 and #2)
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Figure 3.12: Entity Use Code Form

3.7.4 Contract Invoices & Credit Memo Notes

Contract Invoice Support

Problem: Contract Invoices do not technically contain any Pricebook Line Items, just a single line item containing
the cost of the contract. This means that we are sending this ’item’ to Avalara, but with no Tax code linked
to it. Avalara will process this ’item’ as P0000000 - Tangible Personal Property (TPP), not exactly what
you’d want in a contract situation.

Solution: Create a new ’Item’ on Avalara’s Dashboard and assigning it the proper Tax Codes / Tax Rules

The ability to process Contract Invoices in this release of Sentry can be a little confusing when linking up with
Avalara. To process and tax Contract Invoices with Sentry and Avalara:

How To: 1. Log into the Avalara Dashboard 2. Click Organization 3. Click Items -> New 4. Item Code: Enter the
Contract Type’s Name, with "con-" added to the front (Note, "con-" is REQUIRED for this to function properly)

1. Inside Tigerpaw, get a list of your Contract Types that you’d like to link with Avalara

2. Log into Avalara’s Dashboard

3. Click Organization > Items > New

4. Type in con- and Contract Type’s name in all lower case letters and no spaces between any of the words.

(a) “con-” is required to ensure that in the rare case where you could have a real Pricebook item with the
same name as your Contract Type

(b) Example:

Tigerpaw Contract Type Avalara Dashboard Item
One Year con-oneyear
Hourly con-hourly

My Contract Type con-mycontracttype

5. Enter a Description

6. Select/Enter a Tax Code:

(a) Click Browse button Set the Category to "Avatax"
(b) Click Go (Green button)
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(c) Find and Open the Services Section
(d) Locate the Tax Code that best fits your Contract Type
(e) Click on the Tax code

7. Click Save

8. Finished (Repeat Steps 1-7 for additional Contract Types)

How it works: Whenever an item is sent to Avalara that is missing a Tax code, Avalara will search your Dashboard
for any saved items with a matching name. If a match is found, Avalara will use any Codes / Rules associated
with it. When sending a Contract Invoice to Avalara, Sentry will take that Contract Type’s name, add on the
“con-” and remove any spaces, then assigns it to your Invoice item’s Tax code.

Note about Credit Memos and Avalara

The Avalara module supports Tigerpaw’s “Merchandise Credit” and “Price Credit” memos only. To avoid any audit
issues that could arise, “Tax Credit” Memos will not be processed through Avalara. You may still process them
manually with Tigerpaw and/or your accounting software, but we do not support or encourage this method. The
best way to handle fixing an invoice that accidentally included tax is to void the invoice in all systems and recreate
a new invoice after applying a customer’s tax exemption code.

3.7.5 Additional Reports

Since Sales Tax and Sales Taxes Rates in Tigerpaw are processed on an Invoice level and not the individual Line Item,
the default Tigerpaw reports do not display individual Line Item’s Sales Tax and Rates. However, Tigertrak offers
customized versions of the Invoice and Contract Invoice reports that take advantage of this data. Please contact us
for more details. (See figure 3.13)

3.7.6 Review Output Messages

The Avalara module provides seamless tax calculation, however time should be taken occasionally to review output
messages from Sentry. During operation, if the Avalara module encounters any difficulties, a warning, or error is
displayed, and saved to the status log. Warnings are potential problems which may require attention, but which did
not prevent the process from completing. Errors prevent the process from completing. If an error is encountered,
a full description of the error is written to the invoice’s posting exception, and the invoice is flagged to not be
processed again until the problem is resolved, and the hold flag is removed through the Avalara Options in Sentry,
or by releasing the invoice from on hold status in Tigerpaw (the invoice will go back on hold, but the error will be
cleared for reprocessing). After an invoice has been processed successfully, it has been committed to Avalara. If the
invoice must be changed, it must be voided in Tigertrak, and a new invoice created. Additionally, the invoice must
be canceled in the Avalara Dashboard on the web.
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Figure 3.13: A Custom Invoice Report w/ Line Item Taxes
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Appendix A

Trouble Shooting FAQ

Q: Why hasn’t anything moved over to the accounting system?

1. When you start Sentry, if you do not see “Tigerpaw database <version> confirmed..”, then Sentry is not
connected to the Tigerpaw database. See section 2.2 for finding the Sentry setup wizard, or general options to
reconnect with the database.

2. When you start Sentry, if you do not see “QuickBooks connection verified..”, then Sentry is not connected with
QuickBooks. See section 2.2 for finding the Sentry setup wizard, or section 3.6 on establishing a connection
with the accounting system. Other things to look for:

(a) Has someone logged into QuickBooks and locked the file in Single User Mode?
(b) In QuickBooks, under Edit > Company Preferences > Integrated Applications, is Tigertrak access allowed;

does it log in with a user created specially for Sentry?

3. Both the accounting link module and sub-modules must be enabled so that Sentry knows what you want to
use. To enable a module, or sub-module, go to File > Module Options, and check each desired option box along
the top when viewing the modules options. See section 3 on page 7 for detailed descriptions of each module.

4. Sentry must be running for the accounting link to operate.

5. Sentry is not 100% real time. Instead, it periodically executes. The Execution Interval is the amount of time
which must pass before Sentry executes and between executions. This time can be adjusted under File >
General Options. Read important information about the Execution Interval in section 2.3 and in our Errata
section.

6. If you’ve made it this far, and still don’t have any luck, check out the next Question.

Q: Where are my (Invoices|Payments|JournalEntries); they’re not in my
Accounting System?

See if there are any clues in the results table. Most of the accounting link sub-modules have a results table where
erroneous exports are stored with a [usually] human-readable message hinting at how to correct the problem. If
you’re familiar with your accounting system, correcting the problems should be a breeze.

1. Go to the File [menu] > Module Options > [Accounting Link] > [Sub-Module] > View Results [button].

2. Double clicking on a failed export will give you the reason for the failure.

3. Correct the problem.

4. When viewing the results, click the Clear Results button.

Any stuck invoices will try and export again the next time Sentry executes. If there are additional errors, repeat this
process. If you get something real wild in there, call into support, and we’ll explain it the best we can.

25
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Q: I’m getting a bunch of errors on the status screen, but they all say
3140. What does that mean?

..or some other worthless error number. See the above question “Where are my (Invoices|Payments|JournalEntries);
they’re not in my Accounting System?” for instructions on reviewing the results table.

Q: Why doesn’t the Tigerpaw Database version match my version of
Tigerpaw?

The database version we reference during initialization doesn’t match (unless by luck) the version of Tigerpaw that
you’re on, so don’t sweat it. Unless where noted in the module descriptions (section 3), Sentry is compatible with
Tigerpaw version 10.5 and beyond.

Q: I have purchased Sentry, but when I register it says I am in a trial
period!

This is a procedural thing. It sometimes takes a few weeks until we update our customer inventory with your
purchase, and during that time you’ll be in a demo period. Everything works, and once your account is updated
your copy of Sentry will be fully authorized.

Q: What is Case Sensitivity?

Text sometimes exhibits case sensitivity; that is, words can differ in meaning based on differing use of uppercase
and lowercase letters. Words with capital letters do not always have the same meaning when written with lowercase
letters.

Example:

ABC ABC Match
ABC abc No Match
abc abc Match
Abc aBC No Match
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Errata

It happens: technical problems occur. We’re going to use this section to detail some of the more prominent issues
we are aware of, and aren’t able to solve.

Duplicate Payments

Duplicate payments can be exported to the accounting system under certain circumstances. There are a couple of
technical reasons why there is no simple solution to this problem. They have to do with the way payment objects
are viewed between the two programs, and how Tigerpaw handles the entry of payments (a lack of entry finalization
by “posting” the receipt and payments).

Because Sentry automates the batching process, as someone enters a receipt against an account, and payments
against the account’s invoices, if Sentry were to execute before all payments for that receipt were entered duplicated
amounts will be exported.

To clarify this issue, we’ll use an example.

1. Suzie has received a check in the amount of $1,000 from ABC company to pay off invoices #230, and #231.

2. Suzie enters a receipt for $1,000, and begins specifying payments. First, she creates a payment of $700 to be
applied to invoice #230. She would then create a second payment for invoice #231, but before she has time to
do that Sentry executes.

3. Sentry sees the receipt for $1,000, but with only one payment for $700. So Sentry exports the receipt, and
payment to the accounting system. Sentry correctly exports the $1,000 receipt, and applies the payment of
$700 to invoice #230, but leaves the remaining $300 as an unapplied overpayment for ABC company.

4. Suzie continues to create the remaining $300 payment against invoice #231.

5. Sentry will then export the payment for $300 against invoice #231, leaving the $300 overpayment.

The only reports of this problem were from users with an execution interval of 1 minute. Our current workarounds
for this problem are to increase the execution interval to 10 minutes or more, significantly decreasing the chance of
this happening; manually executing Sentry; or not running Sentry when receipts are being entered into Tigerpaw.

Invoice Trade-In values not supported

Invoices created with a Trade In value go over to QuickBooks without the trade in amount deducted from the Invoice
balance. This really cascades into all kinds of mess which simply deducting that amount from the invoice doesn’t fix
because of the accounting involved.

27
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Discount Quirk

There is a discount section on a Service Order under the Totals tab. Using the discount area is supported with our
accounting link, but there are two scenarios which you should be aware of.

1. Do not use the “Sell As” feature to increase a Service Order’s total.
This causes backwards G/L entries to be created. Sentry will not export these G/L entries and if they were to
go over they would skew your numbers.

2. Discounting 100% (or the full amount) of a Service Order’s total causes a discrepancy between Tigerpaw and
QuickBooks once exported.
A bug out of our control causes tax in QuickBooks to be charged for a 100% discounted invoice. To fix a 100%
discounted invoice that has already been sent over to QuickBooks, simply change the Discount line added in
the QuickBooks invoice to “TAX” from “NON”. This is only experienced when discounting 100% (or the full
amount) of an SO’s total.

Both of these issues have a similar workaround. Use a line item to increase the cost of an invoice, or to discount the
full amount.

Progressive Billing

Progressive billing is supported by Sentry, however Tigerpaw allows the modification of SO parts used until the final
invoice has been created. This can create the situation where a final invoice is actually a negative amount. This is
a pretty awkward situation. The invoice may not export (because invoices must be positive) and the G/L entries
associated with the cost and income of this invoice will not export since they would create negative credits which
don’t belong in your accounts.

Best practices dictate that instead of removing items from a service order in the midst of progressive billing, it would
be best to complete the invoice and issue a merchandise credit memo to balance the total. This not only applies to
the removal of items, but addition of items as well which would be best handled with a change order.

QuickBooks Payment Export Errors & TxnID mismatches

This section was originally written for payments, but has since been found to apply to the purchase order export
as well. A portion of our QuickBooks users have experienced errors exporting payments to QuickBooks because
of database pointer problems in the QuickBooks data file. The error “Object <12345-1234567890> specified in
the request cannot be found” is received when trying to apply a payment to an invoice. This is, to the best of
our knowledge, a QuickBooks bug caused by a kind of corruption in the QuickBooks data file. In this error, the
transaction ID (the long string of numbers and letters surrounded in angled brackets in our example error above)
which QuickBooks claims cannot be found was actually provided by QuickBooks! The process goes something like
this:

1. Sentry: “Hey, QuickBooks, I’ve got a payment here which I’d like to apply. Can you tell me where invoice
number X for customer Y is?”

2. QuickBooks: “Sure, you can use Transaction ID <12345-1234567890> to find that invoice!”

3. Sentry: “Thank you! Here’s the payment and I would like it to be applied to Transaction ID <12345-
1234567890>.”

4. QuickBooks: “Whoa! Wait a second there, cowboy. That transaction doesn’t exist!”

The best advise we can give for this problem is to perform these steps:

1. Shut down QuickBooks
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2. Defrag the drive that the QuickBooks company file resides on

3. Open QuickBooks, and under the QuickBooks Utilities, verify, rebuild, and clean up the company data

This has resolved the problem for many, but not all of our customers. You can view the number of database fragments
by hitting “F2” in QuickBooks. More than 100 is bad1, our suggestion would be to keep the number of fragments
below 20.

If this solution does not work for your company file, then the best alternative is to manually batch the stuck payments.

QuickBooks Nightly Backups

We have had a small number of users suggest that repeated QuickBooks company file freezes and, in some cases,
corruption was linked to their nightly backup of QuickBooks. Typically users and programs utilizing the QuickBooks
SDK cannot connect to QuickBooks when a backup is in progress, however there appears to be an unknown link
here that must be mentioned.

Users experiencing this problem have resorted to stopping Sentry at night. Typically restarting the QuickBooks
services unlocks a frozen company file.

Avalara Errata

Avalara is a great solution for a number of our customers doing business in many states or in states which have more
tax jurisdictions than anyone would care to manage manually. Tax service integration into Tigerpaw in a complex
subject and the reality is that we are unable to provide a perfect integration. While Avalara is a time and money
saving service for many Tigerpaw users, some of the following issues are show-stopping for certain customers and we
want to be as up-front as possible about our limitations in integrating this service.

Quotes will not calculate tax

This one’s up front, because it’s dissuaded the largest number of potential Tigerpaw-Avalara customers. Our inte-
gration with Avalara will calculate sales tax on Invoices but not on quotes. These are two very different areas of
Tigerpaw and enhancing our integration to include quotes is not a simple feat.

1. There is no point at which a quote is considered complete before conversion to a service order. This makes it
difficult to determine when a quote should sent to Avalara for tax calculation.

2. Quotes are subject to change at any time and without a point of completion it is not easy to identify when a
quote’s tax needs to be recalculated.

3. Finally, even if we were to overcome the technical difficulties in integrating quotes they could never be 100%
accurate. The warehouse location from which items are shipped has an effect on the amount of tax charged.
The source location is finalized only when posting an invoice and is not specified in the quote creation process.

We are unwilling to pursue integrating Avalara with Tigerpaw quotes because it would be a technically difficult, time
consuming endevor that ultimately will not be precise enough.

Central Billing Invoices not yet supported

Tigerpaw’s Central Billing is not currently supported by our Avatax connector at this time. Central billing is
handled in a separate tables from regular invoices making this feature difficult to support. At this time we prevent
this Tigerpaw option from being enabled so that an unrecoverable situation is not created.

1Intuit KB Article 1003206 http://support.quickbooks.intuit.com/support/pages/knowledgebasearticle/1003206

http://support.quickbooks.intuit.com/support/pages/knowledgebasearticle/1003206
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Tax Credit Memos are not supported

Tax credit memos are generally a bad idea. Instead the invoice should be voided and recreated. You will encounter
all kinds of problems if you issue a tax credit memo followed by additional merchandise or price credit memos. Void
the invoice in both systems (Tigerpaw and Avalara) and recreate the invoice to avoid trouble.

Price Credit Memos are not perfect

We can only pass two simple, prorated “Taxable” and “NonTaxable” items to Avalara when performing a price credit
memo rather than referencing each item individually with their proper tax code.

To properly send a price credit memo to Avalara we would need to prorate each individual invoice line item by the
price credit memo amount. We would also have to take into account all previous tax or price credit memos, and
possibly combine all the invoice techniques such as progressive or partial billing. The level of precision necessary to
properly handle price credit memos is technically out of reach.

Avalara & Progressive Billing

Our Avalara integration into Tigerpaw supports progressive billing in Tigerpaw with a catch. Tigerpaw’s progressive
invoices do not contain line items until the final invoice is created. Items can still be added and removed from a
progressive invoice until the final invoice. Therefore, Avalara cannot process tax on an invoice until the final invoice
is created.

Legally, you [most likely] owe sales tax immediately upon invoicing. I’m told, however, this progressive invoice could
be construed as a deposit. You most certainly should talk to a professional before utilizing this combination of
software features. We have suggested using the deposit feature of Tigerpaw instead to avoid misunderstandings.

Avalara & Managed Service Agreements / Automated Invoices

Invoices which are generated, approved, and mailed to the customer immediately will not have time to accumulate
tax through Avalara.

Avalara & Prepaid Contracts

Prepaid contracts are interesting in how they work within Tigerpaw. When a customer purchases a prepaid contract
it is like having purchased a credit. The credit remaining is deducted as services are rendered (not when invoiced).
The deduction includes tax. I’m going to repeat this. The balance remaining on a prepaid contract, including tax,
is reduced as service is rendered on the Service Order level; not after invoicing. This may make sense because you
want to know when the customer has exceeded their allotted time so they can be informed they’ll receive an invoice
for further work. Our Avalara link only taxes on the invoice level. We can deduct the tax amount from the prepaid
contract after Avalara calculates this tax, but our integration is not without flaws:

• If you have a tax code other than Avalara Tax Group set on the SO before adding any line items, you will
charge tax against the prepaid contract during the SO, then after invoicing. Invoicing the SO and changing
the tax rate on the invoice level has no effect on what has already been deducted from the prepaid contract
(this is a problem not just for Avalara users).

• Don’t void invoices. After you have approved an Avalara invoice, we calculate the tax then deduct this amount
of tax from the prepaid contract. If you void the invoice then recreate, reapprove, and recalculate tax we’ll
deduct the tax again!

• Credit memos of any sort don’t appear to reimburse an amount of credit left on a prepaid contract (this is a
problem not just for Avalara users), so we don’t do anything on the tax level if you issue a credit memo.
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Avalara & Bulk Invoices or Contracts

Invoices created in bulk escape our detection and do not get automatically processed by Avalara. We know that
contracts can be created in this manner through Tigerpaw. We have a script that can be run to add all these invoices
to the queue, so just keep this in mind and talk to us if this situation applies to you.
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Appendix C

QuickBooks Canada

This special section is designed to aid Canadian Tigerpaw-QuickBooks users set up their software for Harmonized
Sales Tax. Harmonized Sales Tax (HST) describes the combination of Goods & Service Tax (GST) with Provincial
Sales Tax (PST).

Provincial Sales Tax

Provincial Sales Tax (PST) is a percentage-based, invoice-wide tax identical to that of U.S. tax. If provinces in
which you do business are subject to PST, than one tax code must be created in Tigerpaw and QuickBooks for each
provinces. This tax works just as US tax does, so if you are only subject to PST and will never charge GST your
tax will transfer as described elsewhere in this manual by assigning a tax code to the invoice.

Figure C.1: Provincial Tax Code in Tigerpaw

Goods & Service Tax

Goods & Service Tax (GST) is enabled in Tigerpaw by enabling GST through Tools > Options > Taxes. By
unchecking “Hide GS Tax related information in windows”, Sentry understands that you are a Canadian Tigerpaw
user and will be using GST. You must then set a TaxID and Vendor Rate where indicated. Please see the Tigerpaw
documentation for help for the most detailed and up-to-date instruction regarding GST setup. If you will not be
utilizing GST, do not toggle this option.

GST is added to an invoice without assigning a tax code to an invoice. If you are only charging GST, then an exempt
tax code should be what is used on invoices. GST will be added to these invoices based on the rate specified in
Tigerpaw’s Tax Options shown below.

When utilizing GST one must continue onto the next section and properly setup tax in QuickBooks.
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Figure C.2: Enable GST in Tigerpaw

Harmonized Sales Tax

Harmonized Sales Tax (HST) is the combination of both PST and GST. Although HST is equal to a sum of GST
and PST, because some items in an invoice may be GST exempt creating a single tax code to be applied to the entire
invoice is not accurate. For Canadian users to fully and accurately setup taxes between Tigerpaw and QuickBooks:

1. One PST tax code must be setup in Tigerpaw.

2. One PST, GST, and HST tax code must be setup in QuickBooks matching the rate of tax in your provinces,
GS Tax rate, and sum of the two respectively.

3. You must use the Manage Sales Tax wizard in QuickBooks to configure your line item sales tax codes P, G, H,
and E representing items which are subject to PST, GST, HST, or no tax at all.

Figure C.3: QuickBooks GST, PST, and HST Sales Tax Items
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Figure C.4: QuickBooks Sales Tax wizard
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Appendix D

Legal Stuff

Tigertrak Sentry Copyright (C) 2004-2016, Tigertrak / Acteon Networks, LLC

DotNetOpenMail Copyright (C) 2005 Mike Bridge

iTextSharp Copyright (C) 1999-2007 Bruno Lowagie and Paulo Soares

The Acteon, and Tigertrak logos, and all related elements are trademarks of Acteon Networks, LLC.

The Tigerpaw name, logo and all related elements are trademarks of Tigerpaw Software Inc.

The Intuit and QuickBooks logos, and all related elements are trademarks and service marks of Intuit Inc., or one
of it’s subsidiaries, registered in the United States, and other countries.

The Adobe logo and all related elements are trademarks of Adobe Systems Inc.

The Microsoft logo and all related elements are trademarks of Microsoft Corporation.

The Avalara logo and all related elements are trademarks of Avalara
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